DESCRIÇÃO

Pasta Search está consumindo muito espaço na Sense Share

 

CENÁRIO

Qlik Sense Enterprise qualquer versão.


CAUSA

Com o uso do Smart Search (Pesquisa Inteligente) no Qlik Sense Enterprise, a pasta Search (%SenseShare%/Apps/Search) vai criando índices para cada App.

 

SOLUÇÃO

Com o uso frequente do Smart Search, a pasta Search (%SenseShare%/Apps/Search) começa a criar vários índices de busca, consumindo espaço em disco.


Esses arquivos podem ser removidos manualmente, entretanto, existe uma forma de automatizar esse processo mudando alguns parâmetros nos arquivos do Sense.


Qlik Sense Server%PROGRAMDATA%/Qlik/Sense/Engine/Settings.ini
Qlik Sense Desktop%USERPROFILE%/Documents/Qlik/Sense/Settings.ini

                                

 No servidor onde está instalado o Sense, pare os serviços Qlik Sense Engine e Qlik Sense Service Dispatcher:



Navegue até a pasta da Engine e abra o arquivo Settings.ini com um editor de texto (notepad++/bloco de notas, etc.)



Adicione os seguintes campos:


ServerPurgeSearchIndexFileInterval e ServerSearchIndexFileDirectoryMaximumSizeInMBytes 



O valor do primeiro campo ServerPurgeSearchIndexFileInterval é referente ao intervalo de tempo, em segundos, que essa limpeza vai ocorrer. O valor padrão é 3600, ou 1 hora.


O valor do segundo campo ServerSearchIndexFileDirectoryMaximumSizeInMBytes é referente ao valor que a limpeza irá ocorrer conforme o tamanho da pasta de cada App. 


No exemplo acima, essa limpeza ocorrerá a cada 1h, mas somente se a pasta de cada App na pasta Search ultrapassar os 1024mb.


Obs: Os dois campos precisam estar configurados, caso contrário, a limpeza de arquivos não acontecerá.


Após realizar esse procedimento, salvar o arquivo Settings.ini e inicie os serviços da Engine e do Service Dispatcher.


Para fazer esse procedimento no Qlik Sense Desktop, navegue até a pasta: 

C:\Users\<username>\Documents\Qlik\Sense\Settings.ini 

Onde "username" é o nome de usuário de quem está usando o Sense Desktop.


E repita os mesmos procedimentos acima, entretanto, nesse caso não será necessário reiniciar nenhum serviço.



DOCUMENTAÇÃO DO FABRICANTE

https://help.qlik.com/pt-BR/sense/May2023/Subsystems/Hub/Content/Sense_Hub/Search/use-smart-search-tool.htm

https://community.qlik.com/t5/Official-Support-Articles/Search-Folder-Growing/ta-p/1714156

https://community.qlik.com/t5/Official-Support-Articles/How-to-modify-Qlik-Sense-Engine-s-Settings-ini/ta-p/1714789